MetForm Pro -Advanced Elementor Form Builder

Please update MetForm Pro -Advanced Elementor Form Builder 3.2.0 to 3.8.0. @Steve

Hi BigMaster,

We would LOVE to update to its latest version, but we encountered an issue with the activation with its latest version. We’re unable to bypass the security in its latest version, as it’s making a lot of server API calls. We will update the file as soon as possible once we got a solution for this.

Please read this topic for more information:

1 Like

Please update MetForm Pro -Advanced Elementor Form Builder from 3.8.2 to 3.8.3. @Steve

Please update MetForm Pro -Advanced Elementor Form Builder from 3.8.2 to 3.8.3. @Steve

MetForm Pro -Advanced Elementor Form Builder has been updated to 3.8.3. You can download this version from here.