Redis Cache Pro

Redis Cache Pro has been updated to 1.19.0.

Please update Redis Cache Pro (Object Cache Pro) 1.19.0 to 1.20.0. @Steve

1 Like

Redis Cache Pro has been updated to 1.20.0.

Redis Cache Pro has been updated to 1.20.1.

Redis Cache Pro has been updated to 1.20.2.

Can You provide extra token key for Object Cache pro???

it does not work . Can you give me information on how to activate it?

https://objectcache.pro/docs/configuration/
You need to configure the plugin in the wp-config.php file

Add this lines to wp-config.php

Recommended configuration

define(‘WP_REDIS_CONFIG’, [
‘token’ => ‘u0QZkTTB9g1klns3AFcVxhyrSsVWkR0iEiiR7WerupnTjjlzqiE6b1XUUPQ7’,
‘host’ => ‘127.0.0.1’,
‘port’ => 6379,
‘database’ => 0, // change for each site
‘maxttl’ => 3600 * 24 * 7, // 7 days
‘timeout’ => 1.0,
‘read_timeout’ => 1.0,
‘split_alloptions’ => true,
‘debug’ => false,
]);

define(‘WP_REDIS_DISABLED’, false);
High Performance Configuration if you get zstd error, delete this line from your wp-config.php

define(‘WP_REDIS_CONFIG’, [
‘token’ => ‘u0QZkTTB9g1klns3AFcVxhyrSsVWkR0iEiiR7WerupnTjjlzqiE6b1XUUPQ7’,
‘host’ => ‘127.0.0.1’,
‘port’ => 6379,
‘database’ => 0, // change for each site
‘timeout’ => 1.0,
‘read_timeout’ => 1.0,
‘compression’ => ‘zstd’,
‘serializer’ => ‘igbinary’,
‘async_flush’ => true,
‘split_alloptions’ => true,
‘prefetch’ => true,
‘debug’ => false,
‘save_commands’ => false,
]);

define(‘WP_REDIS_DISABLED’, getenv(‘WP_REDIS_DISABLED’) ?: false);

Hello,

I have installed wordpress on my Synology server using this tutorial.
I have redis on a separate docker as you can see in the stack file:

 redis:
    image: redis
    hostname: wordpress-redis
    container_name: WordPress-REDIS
    user: 1026:100
    healthcheck:
     test: ["CMD-SHELL", "redis-cli ping || exit 1"]
    volumes:
      - /volume1/docker/wordpress/redis:/data:rw
    environment:
      TZ: Europe/Bucharest
    restart: on-failure:5

I have the normal redis plugin activated, everything works well.
I tried adding this to wp-config.php and activating the plugin redis cache pro from Festinger but I get a white screen.

define('WP_REDIS_CONFIG', [
'token' => 'u0QZkTTB9g1klns3AFcVxhyrSsVWkR0iEiiR7WerupnTjjlzqiE6b1XUUPQ7',
'host' => 'wordpress-redis',
'port' => 6379,
'database' => 0, // change for each site
'timeout' => 1.0,
'read_timeout' => 1.0,
'compression' => 'zstd',
'serializer' => 'igbinary',
'async_flush' => true,
'split_alloptions' => true,
'prefetch' => true,
'debug' => false,
'save_commands' => false,
]);

I tried to deactivating the normal plugin first, install manually, etc. I am lost as to how to switch to the pro version.

Could someone please provide a clear step-by-step explanation ? Otherwise I don’t mind giving a few bucks to someone to help if I can get a performance improvement using the pro version.

Thank you!

‘compression’ => ‘zstd’,
‘serializer’ => ‘igbinary’,

these may need installing on the server?

basically its like for ubuntu/debian
sudo apt install php-zstd php-igbinary

RHEL/Fedora be similar, just find the correct package with dnf search or something.

i saw this when i used object cache pro previously.

this is just a suggestion to check, i am not support just another customer.

I’m getting
The Object Cache Pro license token is invalid and plugin updates have been disabled.

How can I fix this?

Thank you!

Ping to @Martin

Hi @apintocr,

What token have you used?

This one

'token' => 'u0QZkTTB9g1klns3AFcVxhyrSsVWkR0iEiiR7WerupnTjjlzqiE6b1XUUPQ7'

As shared above here.

Thanks for your reply.

@Steve could you please check this plugin and replace it? Thanks.

The file has been replaced now, Please reinstall the plugin.

1 Like

Redis Cache Pro (Object Cache Pro) has been updated to 1.20.2. You can download this version from here.

1 Like