YOAST SEO Premium

The errors seem to refer to addons. I currently have Elementor, Elementor Pro and WooCommerce installed. Maybe a link?

Hi @Risengan,

I’m chiming in here. Are the errors only returning with WP_debug enabled?

Also, is YOAST the only plugin returning these data?

Hi @Martin,

WP_debug is disabled.

I think so because /wordpress-seo/ comes from Yoast SEO plugin and I only have these errors displayed.

I’d like to point out that these errors appear on all my sites and that they all have Elementor Pro installed, but not necessarily Woocommerce (due to my answer above) if this can help.

Please update YOAST SEO Premium from 22.3 to 22.4.0. @Steve

YOAST SEO Premium has been updated to 22.4. You can download this version from here.

One month and still present… Please, fix this. @Steve @Festinger
In addition to displaying all these errors, Yoast SEO Premium doesn’t work properly and no longer even shows up in the Festinger Vault plugin for updates.

The file has been replaced, The product is tested , working fine.

I get this sometimes…

I clear the cache (WP Rocket) and it vanishes!

Give it a try

Please note that we are rebuilding our Festinger Vault plugin as we speak and a whole new version will be released by the end of this month. All automatic update issues should be resolved by then.

Thanks for your comment, I hope this helps!

The PHP errors (undefined property) are still present, sadly… (but the plugin is now visible on the Festinger Vault plugin, thanks!). The errors are only displayed on the installed extensions page. Does this help? All my sites have these errors.

This problem is really annoying, because there are so many errors that I can’t even access my sidebar:

Feel free to send us temporary admin access to hello@festingervault.com and I will check the issue for you personally.

1 Like

Ok, thanks! Email sent.

Hi @Risengan,

Our team has addressed your issue.
Can you please confirm that your problem has been resolved?

The solution: @Risengan activated both the free and pro versions simultaneously, which clashed. We deactivated the free version, and all errors were varnished away.

Thanks for your reply and your help. Sadly, the PHP errors are still here (only on the Installed plugins page of WordPress).

Moreover, Yoast SEO doesn’t give me the choice of activating only the Premium version, apparently the free version is required for the Premium version to work (as with Elementor and Elementor Pro):

Hmm… I am sorry to read that.

I forwarded your concern to one of our senior developers to check the issue here. We tried to replicate the problem in our localhost dev environment, but we could not do so.

I’ll keep you updated.

Here are the informations I can give you:

  • This happens on all my sites, here are the similarities between them: They all have Jetpack, Elementor, Elementor Pro, WP Rocket and Festinger Vault plugins installed. I’ve uninstalled them all one after the other, having cleared the server and browser cache, and it still hasn’t worked, so I don’t think the errors are coming from these plugins.
  • All my sites are configured in French.
  • I’ve just seen that the errors were also displayed on the Yoast SEO General page (in addition to the Installed plugins page) and not on the other Yoast SEO pages.
  • Yoast SEO Premium was installed in the past and worked perfectly before, but this happened after an update.
  • Examination of the lines of the plugin code mentioned by the errors reveals that these are all references to $subscription. Counting the fact that these errors appeared after an update, without any action on my part, I think it’s an error stemming from the plugin’s activation.

I hope this helps. Thanks a lot for your help!

1 Like