Aelia WooCommerce EU VAT Assistant

Download Link:

This is a support topic for Aelia WooCommerce EU VAT Assistant

The intention of this topic is to give you the opportunity to discuss problems and difficulties with other Festinger Vault customers, e.g. how to address incompatibilities or fix bugs, report malfunctioning features, or get help on how to configure this download.

:warning: You can ask us for update requests here as well! :love_you_gesture:

To request an update of a particular theme or plugin, kindly let us know your preferred version number and we will update it as soon as possible. Although update requests usually do not make much sense because we publish them as soon as they are available and we have the time to upload them.

Aelia Woocommerce EU VAT Assistant is discontinued, please vote here to add the recommended alternative WooCommerce European (EU, UK, etc.) VAT / IVA Compliance (this alternative has been recommended by Aelia developer itself.

+1 Vote ? Just Click Here : Please add WooCommerce European (EU, UK, etc.) VAT / IVA Compliance

(Source Aelia recommend Woocommerce European VAT / IVA Compliance : From Aelia EU VAT Assistant to Simba Hosting's EU/UK VAT Compliance)

Aelia WooCommerce EU VAT Assistant has been updated to 1.9.16.191004.

Important: the Aelia EU VAT Assistant reached its end of life on the 30th of June 2022

As indicated in our press release from January 2022, the Aelia EU VAT Assistant reached its end of life on the 30th of June. The plugin is still available from the WordPress repository, it’s fully functional and compatible with the latest version of WooCommerce, but it’s no longer being actively developed. Due to that, we won’t be able to provide assistance for it, nor guarantee the release of new versions or implement new features.

You can find more information about the EU VAT Assistant, as well as the recommended alternative solution, in our original announcement: VAT OSS Compliance – From Aelia EU VAT Assistant to Simba Hosting’s WooCommerce EU/UK VAT/IVA Compliance.


Festinger edit: if the following plugin receives enough votes, we’re happy to add it:

We’re closing this topic as it’s not being supported anymore.